safe.report.extractors.minimum_needs module